Instalar Java en Ubuntu 10.10

22 Oct

Estos son los pasos que podéis seguir si queréis disfrutar de Java en Ubuntu o Kubuntu 10.10.

Iros a consola y escribir

sudo add-apt-repository ”deb http://archive.canonical.com/ubuntu maverick partner

(Ojo con las comillas cuando copiéis este texto, ya que si lo ponéis directamente en consola las comillas se copian de forma rara y os dará error. Copiad todo el fragmento y posteriormente modificadlas al pegarlas en la consola, para que no haya problemas con las instalación de Java en Ubuntu 10.10).

Luego

sudo apt-get update

Y una vez hecho eso,

sudo apt-get install sun-java6-fonts sun-java6-jdk sun-java6-plugin

Cuando termine la instalación de los paquetes, podréis disfrutar de Java en vuestro PC, así como del plugin para ver en Firefox o Chrome cualquier aplicación en Java.

61 thoughts on “Instalar Java en Ubuntu 10.10

  1. a mi me aparece lo siguiente:
    W: Imposible obtener http://mx.archive.ubuntu.com/ubuntu/dists/maverick-updates/multiverse/binary-i386/Packages.gz 404 Not Found [IP: 91.189.91.13 80]

    W: Imposible obtener http://extras.ubuntu.com/ubuntu/dists/maverick/main/binary-i386/Packages.gz 404 Not Found

    E: Algunos archivos de índice no se han podido descargar, se han ignorado,
    o se ha utilizado unos antiguos en su lugar.

    a que se debe? como le pongo java?

  2. Hola Diego, hice lo anterior y me sale esto

    enba@enba-desktop:~$ sudo apt-get install sun-java6-fonts sun-java6-jdk sun-java6-plugin
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    El paquete sun-java6-fonts no está disponible, pero algún otro paquete hace referencia
    a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
    encuentra disponible desde alguna otra fuente
    E: El paquete sun-java6-fonts no tiene candidato para su instalación
    enba@enba-desktop:~$

    ¿Qué puedo hacer?

    • ¡Hola!

      Lamentablemente hace mucho tiempo de este post y ya no tengo Ubuntu 10.10 para probarlo 🙁

      Sé que Canonical eliminó varios de los paquetes Java de los repositorios. Prueba a hacer lo siguiente:

      sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner"
      sudo apt-get update
      sudo apt-get install sun-java6-jdk

    • Puedes acceder desde el menú, en aplicaciones -> sistema -> consola.

      Me alegro de que pudieses instalar Java en Ubuntu 😉

  3. OK, Muchisisimas gracias amigo, de verdad que si sirve. Haber como funciona con JDownloader, ya mañana paso para informar si funca de a 10 ;D

  4. Pingback: Instalar Java en Ubuntu 11.04 | Un lugar para conspirar

  5. Muchas gracias, aunque llevo unos años con Ubuntu es la primera vez que he tenido que instalar Java y tu información me ha servido de grandísima ayuda 🙂

    • Espero que cuando lleguen Ubuntu y Kubuntu 11.04 la instalación de Java sea más simple… Me alegro de que te sirviese. Un saludo 😉


  6. Cristian:

    hice lo que decías todo bien hasta que después en la terminal me apareció texto de java sun sobre los termninos de sun y aceptar mas abajo pero no era un boton ni tampoco podia escribir en la terminal, haci que la cerre pero no se si se instalo java, creo q no porque el unico motivo por el cual queria java era para firefox y abrir una pagina en java, pero me decia q no tenia java.

    Solo presiona Tab (tabulador) y asi podras aceptar. yo casi cierro tb. Espero lo leas y te sirva.

  7. hice lo que decías todo bien hasta que después en la terminal me apareció texto de java sun sobre los termninos de sun y aceptar mas abajo pero no era un boton ni tampoco podia escribir en la terminal, haci que la cerre pero no se si se instalo java, creo q no porque el unico motivo por el cual queria java era para firefox y abrir una pagina en java, pero me decia q no tenia java. 🙁

  8. Gracias men, estaba desesperado por no hallar la forma de instalar java, saludos, me funciono de 10 y se instalo muy rapido, soy NOOB y no estoy familiarizado en el uso de ubuntu

  9. hermano gracias soy de Venezuela y ubuntu es lo mejor del mundo =9 ahora necesito q me ayudes en algo mi maquina tiene 512 de ram y 40 de disco diro xD es una laptop, como hago para correr l2 hay ? si sabes responde ya tengo el wine…

  10. Muchas gracias, acabo de instalar el ubuntu 10.10 y estoy instalando aplicaciones para luego instalar actualizaciones, y pense empezar por el java y no me aparecia en synaptic cuando escribia ”jdk”, :(, y busque un tutorial y me encontre este, añadi los repositorios editando el sudo sources.list con gedit y ahora esta bajando :D, muchas gracias, un saludo

    • Es que los pasos que puse son para Ubuntu/Kubuntu 10.10, y si no me equivoco, lo que has comentado es para Lucid, que es la 10.04

  11. Gracias, funcionó,

    Al leer lo de las comillas pensé (que no leí) que había que quitar las comillas. En realidad mencionas que hay que introducirlas a mano.

    Gracias de nuevo.

    Nota: Te dejo un enlace de mi página web, por si algún día tienes problemas fiscales y te puedo devolver el favor 🙂

  12. Hola, ante todo gracias por tu atención y tu página.

    He instalado Ubuntu 10.10, pero no me funciona el comando add-apt-repository

    Me sale el mensaje:

    sudo: apt-get-repository: command not found

    ¿Sabes como tengo que instalarlo o donde localizarlo?

    Gracias

  13. Hola resolví el problema con el Gestor de Paquetes, busque la opción de instalar los paquetes que me habías mencionado, ahora los navegadores pueden visualizar java, sin embargo no logro que el programa “”Gepphi” que necesita Java empiece a correr, no se si me podrías orientar, de antemano agradezco todo el apoyo. suerte.

    Elías

  14. Hola de nuevo preguntando, mira en el menú de
    Aplicaciones/Internet/ aparece Sun Java 6 Web start. Según me reporta que esta instalado, sin embargo en los navegadores como Google Chrome, Mozilla Firefox me dice que debo de instalar Java, y me manda a la página, y tengo otro programa “Gephi”, el cual corre en Java, y cuando lo abro me aparece una ventana con la siguiente frase:

    Cannot find Java 1.6 or higher.

    ¿qué puedo hacer?

    Espero que me puedas ayudar, he hecho todo lo que me has recomendado, gracias.

    • Mmmmm lo único que se me ocurre ya, es que vayas al gestor de paquetes, y pongas en el buscador “sun”. Deberían aparecerte como instalados sun-java6-bin, sun-java6-fonts, sun-java6-jdk, sun-java6-jre y sun-java6-plugin. Dime si te aparecen allí.

      Para que te pueda ayudar, aparte de lo anterior, dime qué te sale en consola cuando pones “sudo update-alternatives –config java” (con dos guiones delante de auto).

      Saludos.

  15. Asegúrate de que pusiste “sudo apt-get sun-java6-plugin” y reinicia el ordenador (más que nada por si durante el proceso hubo problemas.

    Si aun así no se instala Java en Ubuntu, prueba a poner em consola “sudo update-alternatives –auto java” a ver si ya se soluciona.

  16. Hola nuevamente gracias, al fin pude instalar el java, sin embargo cuando abro páginas en Google Chrome o en Mozilla y necesitan java, me ponen un mensaje de que lo instale, no se que debo o puedo hacer, agradecería nuevamente tu ayuda.

    Gracias

  17. Hola gracias por la atención, sigo las instrucciones y me aparece este mensaje, espero puedas ayudarme, gracias:

    elias@elias-laptop:~$ apt-get -f install
    E: No se pudo abrir el fichero de bloqueo ‘/var/lib/dpkg/lock’ – open (13: Permiso denegado)
    E: Imposible bloquear el directorio de administración (/var/lib/dpkg/), ¿es superusuario?

  18. Hola creí que se estaban instalando pero al final me apareció este mensaje:

    Los siguientes paquetes tienen dependencias incumplidas:
    sun-java6-jdk : Depende: sun-java6-bin (>= 6.22-0ubuntu1~10.10) pero no va a instalarse
    Recomienda: visualvm pero no va a instalarse
    sun-java6-jre : Depende: sun-java6-bin (>= 6.22-0ubuntu1~10.10) pero no va a instalarse o
    ia32-sun-java6-bin (>= 6.22-0ubuntu1~10.10) pero no es instalable
    Recomienda: gsfonts-x11 pero no va a instalarse
    sun-java6-plugin : Depende: sun-java6-bin (>= 6.22-0ubuntu1~10.10) pero no va a instalarse
    E: Dependencias incumplidas. Intente ‘apt-get -f install’ sin paquetes (o especifique una solución).
    elias@elias-laptop:~$ apt-get -f install
    E: No se pudo abrir el fichero de bloqueo ‘/var/lib/dpkg/lock’ – open (13: Permiso denegado)
    E: Imposible bloquear el directorio de administración (/var/lib/dpkg/), ¿es superusuario?

    Apenas instale el Ubuntu y no entiendo mucho, espero me puedas ayudar.

    Gracias.

    • Prueba a instalar también el java6-bin con “sudo apt-get install sun-java6-bin”
      Si te da problemas, para forzar la instalación, utiliza “sudo apt-get -f install” si te dice que hay dependencias incumplidas.
      Luego haz los pasos de arriba (la entrada del post) 😉

    • De nada, me alegro de que te haya servido, a ver si en las próximas versiones lo ponen más facilito y nos ahorramos todos estos pasos. Un saludo 😉

  19. Tienes ganado el cielo y una buena copa de vino.
    Después de reiniciar di a buscar actualizaciones y ya tengo instalado java 6. Ahora es openoffice el que no permite instalar algunas extensiones. ¿Cómo configurar correctamente Java?
    GRACIAS …y el vino que me tome va a tu salud

    • El problema sigue siendo del primer paso, que no reconoce bien el repositorio. En concreto es por las comillas.
      Prueba a ponerle las comillas a sudo add-apt-repository deb http://archive.canonical.com/ubuntu maverick partner de forma manual. Es decir, copia lo que está en negrita, y luego añade las comillas delante de deb y al final de partner. Lo que sucede es que en vez de añadir en consola las comillas normales (“), están introduciéndose unas especiales (que están como en cursiva), el sistema no las reconoce, y por eso da tantos errores.
      Prueba y me cuentas si te instala ya bien Java en Ubuntu 10.10 😉

    • ¡Hola!
      Ese error suele ocurrir cuando no se introduce correctamente la dirección del repositorio.
      Debes volver a realizar el proceso entero, pero asegúrate que pones en consola sudo add-apt-repository “deb http://archive.canonical.com/ubuntu maverick partner” con las comillas empezando en “deb” y acabando en “partner”.
      Un saludo.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *